Crashing more since latest release on Tuesday


#1

Hi, I do love the mounts and cosmetic shop, but I have been crashing a lot more since last release on Tuesday (8/7/18). On Wednesday, I crashed 5 times doing a dessert shard, but didn’t get to save those ouput logs, I was on default. I switched to proxied and I stopped crashing but paused or lagged a lot in the game.

For hard mode boss 4 yesterday, when boss was 50% i had half the fps ~30-40 fps and crashed during the boss fight, not client crash, but it put me back to login screen and I still had bad fps. I will send you the ouput log for this.

Also recently, its been harder to cast spells, spells were sticking on my wand a lot more. I feel sometimes I get to a point where I would need to press the release button twice to shoot my spell. This would sometimes happen continuously.


#2

I’ve noticed this as well. Quite irritating sometimes.


#3

I’m not really sure what would be going on with the wand sticking stuff. We haven’t made any changes there.

Before Tuesday, were you also on the Default setting when you were crashing less? Were you never crashing at all, or just less? And then were you on Beta or on updfix2 or just the regular branch?

Based on what you’re saying, it sounds like you are having some packet loss to our server (which is leading to crashes on Default but also to lag spikes on non-Default). That would also explain spells “sticking”, since when you send the signal to the server to “cast” the spell it is getting interrupted/delayed.


#4

Before Tuesday, I was on Default and wasn’t crashing at all, just desync-ing issues, failing to cast consistently after two dungeons. So at the beginning of every 2-3 dungeons I always relogged but rarely crashed. I was not using Beta.

With the spells sticking, I had this issue once in a while before release, but after this release, it happens a lot. This happens sometimes spell after spell after spell.

What is better to use between the 3 options at login? Before release I always used default because I can cast consistently fast with it, but just desync every 2-3 dungeons.


#5

Default is typically the “ideal” option because it is more flexible behind the scenes so we can separate data like “I cast this spell” which is more important from data like “I moved my hand 2 inches to the left” which is less important.

Proxied and Simple are both systems where all the data is “equally important” which is why you see lag spikes with those, but at the same time at least it doesn’t crash/disconnect nearly as often. If you haven’t tried Proxied yet it’s worth a shot to see if it helps with lag spikes.

It’s interesting that you’re crashing now Default if you weren’t before, all of the changes we made there in the new patch were all about fixing crashes for a lot of folks. It’s possible I guess it made it worse for some other people but that’s not what I would have expected.

In tomorrow morning’s build I will have a new udpfix2 branch available that you can try that may help. Are you on Oculus or Steam?


#6

I am on oculus. how do I try out the branch?


#7

I have been having the same problem with spells sticking. I have noticed a lot more of my spells sticking, I will experiment today with different servers and the spells sticking, this severely hurts my chain casting for frost three, it seems the server can not read my activation of my spell and or lag might be causing a delay in which it doesn’t read my activation trigger therefore I have to click it again to read.


#8

PM me your Oculus email and I will add you to the Beta channel.


#9

I’ve also noticed the spells sticking. Back when it was just default and Websocket, Websocket worked great for me - practically no issues. With these new 3, none are as good. (I have the game on Steam, play on Oculus Rift, and never opt for beta stuff - I’m not very computer literate). The new default would suddenly send me back to Oculus home mid-game, the middle one (Proxied?) would always make me get stuck forever in a loading screen when trying to go through a portal (like entering the raid area) and the bottom one (simple?) is mostly functional, but the spells occasionally get stuck on my wand. It also seems to take a bit longer loading in, but at least it does.


#10

The other weird thing that I am seeing since latest release is that when I log out (or freeze and go to login) a majority of the time, my character is faced sideways or backwards. Then I try to to click on my name, it’s not recognizing my click. Then I have to force quit the client and restart again to relog.


#11

There is no difference at all between the original Websocket and the new Simple. So if the wand sticking issue is happening on that and it wasn’t before, I suppose it’s possible it’s a new bug. But as I said I’m not really sure what would have changed to affect that.


#12

Yeah okay we’re aware of that and working on a fix. Thanks!


#13

Okay so on the “spell sticking” thing, just to make sure we’re on the same page (because we are attempting to test and confirm this now):

You draw the spell, that goes fine.
You press the button to submit the spell, that goes fine.
It shows you have a spell ready to cast.
Then you press the button to actually cast the spell, and then…?

  • It works but there’s just a bit of a “delay” sometimes between when you actually press the button and when it starts to fly forward?
  • Or you actually have to press the button multiple times to get it to work? As in, if you just press the button once, the spell never actually casts?

#14

So normally when I am trying to spam cast my spells there is an issue with releasing my spell or a lag before my spell even shows which causes when I press the button to activate and release it won’t read it fast enough so it doesn’t shoot when we want it to. This causes mages to trip up and hurts our dps.


#15

I agree with SirAndrew. That is the exact same thing I am seeing, either 1) I press the trigger button, it pauses for a while then spell shoots or 2) I press the trigger, spell is still on my wand and I have to press trigger again.


#16

Okay, so I think that what is actually going on here is that there is a difference in the way that initial objects are represented by the new interpolation system (the thing that “smooths out” the motion of the objects in-game).

That’s why I was asking if it was more of a delay thing or if you actually have to press the button multiple times to get it to work…so you might next time you are in game play with it for like 10 minutes and only ever press the button once and then see if it ever actually doesn’t fire, or if it’s just delayed.

Assuming it’s the interpolation system, I will play around with that a little bit and see if I can speed that part up a bit. Honestly the Runemage spells are weird in general in that they’re the only thing in-game that the client doesn’t just immediately render themselves (like Archer arrows or Musketeer bullets) which is what leads to that little bit of latency at the beginning. It may be that long-term we just want to re-work how that works in general.


#17

For me (on default, rift on steam) what has been happening is -

  1. Draw spell, that goes fine.
  2. Press to submit, that goes fine.
  3. Shows I have spell ready to cast.
  4. Press button to cast, it does cast
  5. Shows I have the spell still ready to cast, but it is false and will go away when I cast my next spell.

#18

Okay we did get that to happen once in like 50 times of casting spells when testing earlier.

Have you noticed any other spell stickiness? Or just that?


#19

Just that for me since the last update.


#20

My experience is that the spells just aren’t responsive after submitting the drawing mainly when fps is low, but also at the training dummy in highsteppe my spells just kinda stay on my wand for a second or two after cast. I’ve clicked the trackpad multiple times (5+) on some occasions and it just takes forever to work.