Freezing or Stuttering


#1

Every 10 or 15 seconds my client freezes for about a half second then catches back up. It’s not something I have experienced in any other game.

I’ve opened my resource manager and tracked everything from CPU use (on a 10 core, 4.5Ghz) to GPU (1080) to even packet receipt and sending and the only thing that seems to match up with the hiccups is the packets stop for a few seconds during that timeframe. I’m on 100Mb and have been for years so, I’m fairly sure it’s not something on my end.

This happens whether I’m around other people or not, whether I’m transitioning, attacking, watching other players, moving, etc. Nothing I do seems to influence it or make it worse or better. I can only assume it’s the client or the server.

My average ping to the login server is 24-25 and that stays constant even through the hiccups (I left the ping -t running in the background while I played) So… I’m stuck here.

It affects my ability to draw runes, hit anything moving with spells and arrows, etc. So basically my own option is to be a warrior and even then I miss combos because of it and miss blocking also.

Any help would be appreciated. Also, anyone else having this issue?


#2

Hi, sorry for the issues - can you send your output_log.txt file to [email protected] ? He can look at it and see if anything stands out on why this would be happening.

You can find it if on Steam at Steam\steamapps\common\OrbusVR\vrclient_Data\output_log.txt or on Oculus at C:\Program Files\Oculus\Software\Software\orbus-online-llc-orbusvr\vrclient_Data\output_log.txt

Just link this thread in your email and we can follow up on it. Thanks!


#3

I already uninstalled it. I’ll give it another try this coming week probably.


#4

This was happening to me as well. I checked with my friends in my party and they all saw the same thing. My spells would literally freeze mid-air and my casting would freeze as well. The spell would register, but take a few seconds to finally cast. We saw it happening all around but I was specifically in the area between High steppe and the twins. This wasn’t local to my machine as everyone in my party also experienced the same lag. When we entered a dungeon the lag spikes were not present.

I have a running theory that it has to do with how tightly the server is enforcing synchronization. For example one of our guild members regularly has high lag due to the internet available in his area. I think the prevalence of lag spikes is higher when their lag is higher.

I don’t remember lag being this bad in the overworld before. I know there was a lot of optimization that went into the network side of things to try and tackle the long term lag that would occur during raids, could that have affected things outside of the raids?

I checked my log file and the line that says current client latency was never above 75ms more in the 40 range most of the time I was playing.

[edit]

I managed to capture a video of it happening. I wasn’t in a party this time, and it didn’t take long. Immediately after I logged in I tried it.


#5

I had this happen to me while I was leveling my warrior today. The game would freeze and then all my hits would register after like 1-2 seconds. Although it was a rare occurrence but I think it happened like 3 times total.


#6

Thanks for that video. It does definitely look like some kind of network lag. It’s interesting that it happened right when you teleported? (Although I think that was accidental)? Is that a common thing where it’s happening when you teleport like that? Or was that just a coincidence?


#7

It just looks that way, if you slow the video down you’ll see that it actually freezes before I teleport. The night before they would freeze even without teleporting and the people in my party saw it freeze too. Last night I played and I didn’t notice it freezing at all in the desert or the desert dungeon.


#8

Are you on the Default or Alternate (Simple/Proxied) connection type?


#9

I’ve seen this happen numerous times, but only in highsteppe. The freeze affects everyone at once, multiple people will comment when it occurs, so it has to be some sort of server lag.


#10

Yeah, I had it happen no matter what area I was in and whether or not there were people around. I’ve tried it on simple and on default network types and both have the same issue. Everyone comments when it happens. Maybe it’s something new? I don’t know. I have only been playing for a week or so.

It’s definitely either the client (as in the software client) or the server.


#11

Simple, however I don’t remember choosing that, it use to be default as I didn’t have issues in the past. I just tried it and I went to my house near guild city and it took just a minute to replicate the issue again. This time the game locked up so hard it wouldn’t let me log out. I tried pulling up Steam and clicking exit game, but it got stuck here. I tried shutting down SteamVR and restarting. Game was still frozen as in it just said exit game in SteamVR rather than launch game. I was even able to launch another game and come back and it still showed the same. I’m going to restart and see if it also happens to me on default and proxy.
[edit]
Just tried it was default and proxied. Results are the same. I was able to log out this time though.

I’ve sent my output log to [email protected]

I can try re-installing, but I would prefer to hold off on that since the bug is very repeatable on my end at the moment.


#12

Yeah I think that’s a different issue that some people seem to be having when transitioning in/out of the Player House.

The only reason I asked about the connection type is it might indicate either a) the entire server having a processing delay or b) some type of network lag in-between the server and all of the clients…if you’re on Default that should rule out b) for the most part so that’s why I was asking.


#13

Since you are online, I’m simply replying since I made an edit to my post while you were typing. I’ve tested out a few more cases.


#14

Also to clarify, I wasn’t inside my playerhouse for my case I was near the bridge directly outside guild city, near the player house.


#15

You’re just standing near the bridge and then the whole game locks up for several minutes and you have to force close it? That doesn’t really sound like a networking lag bug haha.

EDIT: I looked at your log but it looks like you were able to logout successfully and try different connection options like 3 times? I’m not seeing any crashes or indications it was force closed…

Or when you said the results were the same you just mean the initial lag spike was the same, not the whole game locking up and needing to be force closed part?


#16

I just reset the zone that Guild City is in, let me know if that helped at all.


#17

That fixed it, I tried it all across the zone and then travelled to highsteppe. I was able to get it to stuter slightly when I was in Highsteppe but that was after a few minutes of non-stop casting.

Also for clarification. It didn’t show the crash on the log. I’m not sure why. I wasn’t able to log out, so I had to go to SteamVR and click exit game. At which point the option to launch in VR never returned even when reloading steam. I had to restart the computer.

Results being the same referred to the network spike. I’m not to concerned about the freeze. (Although the game locked up on me every time I entered a dungeon, but that was minor in comparison) What I found interesting was that I was alone this time. I looked through the log file and it said 0 nearby players.

Either way resetting the zone fixed it, so it seems like something definitively on the server side. If I run into it again I will update this thread.


#18

Okay, sounds good. That zone had been running for 6 days straight so there was probably some “gunk” that had built up on it, I am going to put in some code to not let the overworld zones run that long with a reset. Thanks for the report!


#19

I just sent a log for a 10 minute play session just now. The lag was definitely there. I wasn’t in Highesteppe until the end of the file. I started in a town with the bees and the pigs (I don’t know town names) where you can “buy” a house (that doesn’t seem to do anything) and made my way on foot to Highesteppe while fighting things along the way. I only saw one person the entire time and I can’t say the lag was any worse or better when I hit Highsteppe, but I did take some some time to beat up on a couple redtails and a dummy and didn’t see any real issues like I did before. If you changed or fixed something in that area, it needs to happen in the others too.


#20

Ahh, saw your message about clearing Highsteppe zone. Most MMOs and persistent multiplayer games have a down-time each day to reset the servers when they require everyone to log out. I’m sure your servers could use that as well.