Grinding devices

#1

it would be nice to have a number to see how long to get each ranks on the teleport device

3 Likes
#2

yeah some sense of fullness would be good or at least an indicator if a kill is counting

2 Likes
#3

The mount is supposed to be the rarest drop- yet it only has blue text. Where is my legendary mount?

#4

I would like to know that I’m doing it right, it would be helpful to see the device actually absorb their essence

2 Likes
#5

Even though I know I’m doing it right I’m fricken out

1 Like
Reborn Patch 10.90
#6

I believe I mentioned yesterday that the rarity levels were just mislabeled on the drops, that is indeed the Legendary Mount that drops.

1 Like
#7

Okay, so I did a grinding machine all the way through this morning. Here are my thoughts:

  1. The first thing I did after finishing level 5 was go back and start all over again…I actually wanted to grind on my main. So…mission accomplished, the grinding fun is back in the game for me.

  2. After I got level 5 on the device I looted my chest (I got two harvester 3s this morning — one on my second level and one on my fifth) and redeployed the device. It was now empty (the colored rings were gone).

  3. I went back to Highsteppe to start all over. I redeployed and started to grind. I got the device back to level 2 fairly quickly, and got the exp message…but no loot at all. No chest appeared, no roll for a rare item, etc. This was disappointing. Is it working as intended?

Do I need to destroy the old one and go ask the npc for a brand new one? I had thought to do this, but figured level 1 is so fast that it didn’t mind risking it.

Some suggestions:

I was uncertain pretty much the entire time if my device was working on the mobs I was killing. The only time I knew if I had been killing the right level mobs was when I got the reward chest.

Is there a range on the device? I would have tested this, but since there is no way to tell if you are getting progress (aside from finishing a ring), I have no idea how far I am allowed to go from it. I basically kept it on my belt the entire time and just dropped it again if I had to move even a short distance from my camping area.

Does the device split kills (like exp) if you are killing with partners? I did the whole thing solo, but not sure if it would have been faster to work as a team or not.

Over all, I had fun with it. I think folks will enjoy playing around with it…especially the fun drops.

1 Like
#8

We are definitely working on an indicator to help show it is working properly. That should also help with the range issue.

You shouldn’t have to buy a new one, no.

Charging the device follows the same rules as gaining XP in a group. Meaning if you kill a mob together, you each get 1/2 the XP (and half the charge). However, the group bonus multiplier is also taken into account just like XP, so a good group of 2 or 3 players who can keep that multiplier up can probably come out ahead vs a solo player depending on how fast they can kill things.

#9

But should I have gotten a new chest when I started over again? I only got the exp message on my second run around (for finishing level one).

#10

Just to be clear I’m not talking about getting a chest icon in the loot…I mean I didn’t get the chest animation in game with all the common items or anything at all. All I saw was the exp message and the ring on my device was now there.

I know that you only have a chance at the rare loot. In my first run I got two rare items out of five chests, which came as chest icons to open up in the big animated loot treasure chest the popped.

#11

Hmmm has anyone else experienced this? I think it should just keep working…

#12

Not sure I like the idea of yet another way to get chests. I do not really see how this game can have an economy.

#13

Haven’t seen it yet - maybe it’s some sort of desync issue? We’ve definitely had issues with world boss chests not popping up before, but that was usually fixed by exiting and re-entering the shard.

#14

What monsters were you killing inside of highsteppe? It wasnt the tutorial monsters near the Highsteppe fence was it?

#15

No, I was killing the monsters near the first public event (right near the second gate).

I definitely got the device to light up and got the exp message from the mobs, just no loot.

#16

Yesterday when I first tried the Grinder I saw the yellow line pop up but I didn’t get a chest.

I then saw the 2nd pink line show up and saw an EXP message but no loot as well.

Then on my 3rd line I received a chest and also my 4th.

Maybe I missed the EXP on the 1st line and maybe I missed the first 2 chests because I wasn’t aware of how it worked but I think I would have saw the chests at least.

#17

My only thoughts would be… raid party perhaps? If you had been queued and somehow kept in the raid group after you left or something? Or if you had 6+ people waiting for the queue to pop or waiting for more guild members to hop on so you could raid? idk.

1 Like
#18

We had a party member also not show a chest once but after walking back and forth around the area of the chest for minutes the chest showed up. (Was in wastelands)

Feels related to loot bags disappear bug and I guess this is going to be a very hard bug to track.

#19

well, you can get rare items that im sure will sell for alot of money

#20

Just finished my second set for the day. this time the chest spawned and then poofed before i could loot. so no chests for me on 2 of 5 levels vor my second run thru…not a happy monkey right now =/