I can't buy via steam wallet (I play with steam) Cosmetic Shop

#1

As the title says, I can’t buy items from OrbusVR Cosmetics’ shop. I tried to buy Nimbus Cloud Mount, the game tells me to take off my headset to confirm my transaction and when I take a look on steam nothing happens or appears.

More details:
I’m on Oculus Rift
I have sufficient money in my steam wallet.
I play with oculus open (only way to have the headset work?), and with steamvr
When I tried buying nimbus cloud, and I exited the game, there was an comfirm transaction via steamvr and not on my regular steam, i’d click approve (I do have enough money for the purchase including tax) and it’d load and nothing would happen. My steam wallet would remain the same.
No nimbus mount neither.
I can’t access Steamvr while in game because clicking on the left “menu” button usually brings up steamvr, but while in OrbusVR it opens up my in game menu.

#2

Hi, can you try without having SteamVR open? Normally the game uses the Oculus SDK to run the game even if you own it on steam and running through SteamVR can lead to some inconsistencies. That may be the cause. If it still doesn’t work, let us know and we’ll investigate further.

#3

It’s kinda weird/finicky. If it helps, I have Oculus Rift and bought on Steam. I launch through Steam, but I have SteamVR disabled. It’s like a window on top of the Orbus window, but I’ve had to click around semi-excessively to find it before. As in, I won’t see it, I’ll look everywhere around Steam and its settings / Steam Wallet, and then a few minutes later bringing the Orbus window back up, suddenly it’s there. I had bought everything in the cash shop in OG over a few months and have bought a couple things so far since Reborn. When someone else was having trouble buying the cloud mount a few weeks ago, I went in to buy something to walk him through it. Despite thinking I’d be a pro by now, it still took “where is it???” and luck/persistence to find. Sadly, he didn’t manage the purchase after several minutes, even after that, and said he’d try again later. I haven’t seen him since to know if it ever worked. So my advice is… keep clicking. Randomly. Minimize windows and bring them back up (careful to avoid full-screening anything). Hopefully it’ll magically appear on top of the Orbus window before too long.

#4

Worked by not having steamvr on!

2 Likes