Just bought game, can't play it, goes to black screen

I bought the game, installed it, created my account and character. The default type connection only leads me to a black screen, but for a split second I can see a message that says “Disconnected” right before the black screen. The proxied connection won’t connect either. The middle option does connect and brings me to the starting place where I see some tutorial stuff. However, about a minute of gameplay and I get a black screen, then it says the game is loading and never loads back up again. I’ve tried several times and get the same result. I’m not on wifi, I have an ethernet cable going into my pc. Internet’s stable and other games are running smoothly. Do I just ask for a refund on this game or is there a fix to this?

Sounds like an issue that the Dev Dudes will have to look into if you send them your output log they might be able to sort it

Output logs to be sent to: [email protected]

Output log log can be found in %userprofile%\appdata\LocalLow\Orbus Online, LLC\OrbusVR

It might be worth trying to make a second character and seeing if it happens on there

1 Like

I did create a new character. I tried that about 3 times, I think. I’ll see about emailing the output log. Thanks.

Hi, just following up to this - sorry for the issues - if you send us your output log we may be able to figure out the cause.

Additionally, I understand you haven’t had any issues with other games but would you be able to try a different connection just to check? Like say, tethered to your phone?

Thank you.

I don’t have wifi on my PC, so I can’t really connect any other way except for ethernet. I’m just about to mail the output file.

I guess they just gave up on me? I haven’t received any replies after they had me do some ping tests and there were no timeouts.

Hi, my apologies for that - we received your last ping test and didn’t have a chance to follow-up on it at the time.

We’re unable to tell what might be going wrong in this case. Seeing by the tests you did your connection should be stable with the game server. The logs you send us just show you getting disconnected as if your connection was cutting out.

This is the first time we’ve seen this issue, so I’m not sure what else we can recommend other than trying a full game reinstall or if you have one, using your phone as a hotspot tethered to your PC to see if it makes any difference.

We’re sorry for the frustration.

Could also try restarting your router to see if that helps

Alright, I’ll try the reinstall and restarting the router. Thanks!

Too late to get a refund sorry man. Maybe some kind of antivirus? It is an mmo technically a life eating virus.