Knights emblem glitch


#1

Hi, im running into a quest glitch in orbus, ive done the demanding chef 2 story quest where i had to get the red truffle from the bandit camp, and i didnt know i was supposed to pick up the knight emblem. I turned in the quest, and my friend told me i had to go back to get the knights emblem to trigger a story quest to get me a mount, so i went back to the bandit camp to get the knights emblem and when i pick it up it does not go into my inventory. Ive tried to put it behind my head like regular items, and ive tried holding it in my hand for 5 seconds, but it just dissapears and dosent go into my inventory, ive checked my journal, and dont have a forest secrets quest, and tried reloging and doing the same thing, but it dosent work, is there anything i can do to fix this?


#2

whats your in game name, we will have to clear out some quest flags to get it to work properly for you, sorry about the issues but ill get it fixed in morning for you.


#3

My in game name is Greyson


#4

As long as you were logged off the game in the last 10 minutes, you should be fixed, make sure to delete all “Red Truffles” from your inventory, then go talk to chef again and get the quest, go to the forest after getting the quest and you should get the “Forest Secrets” quest, then pick up the knights emblem and return to Bishop Roma. Just ensure that you have no red truffles in your inventory before talking to the chef or the quest chain will break.


closed #5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.