Looking for info on broken quests issue

Hi, we’ve seen some reports lately of players having some of their quest objectives not registering, or sometimes even getting broken midway through a quest, for example where suddenly new monsters aren’t counting for kills when they were before.

We’re looking to track this down so we could use some information -

  • Your character name
  • The quest name you’re having trouble with and its current objectives
  • If on PC, a screenshot of the journal with the page would help
  • Output log, you can send it to [email protected], just mention that you posted in this thread and what your name is, or use the in-game report tool.

We also want to know what you were doing before it broke, like did one break simply as you were doing it with nothing else in between?
And if you’ve had this issue before but then it solved itself, what did you do before it started working again?

We appreciate any and all information. Thank you.

2 Likes

Yea had that lately on 2 lore quests or more on my alt, drove me crazy. Will write a bug report next time, don’t wanna post my name etc. on forums; and however I am almost finished anyway, so not sure if I run into it again.

One of the quests was the one where you need to pick up the wood in rainforest (outpost questline), I picked up all 8 wood several times, going by a map with locations, but only 4 were registering.

Same happened on a kill quest (also lore one) which I forgot.

What, to my surprise, did NOT help was a relog!

What possibly helped with the “wood” one was turning in another lore quest, I remember then I suddenly saw the broken one also finish.

The other one also finished suddenly when I did something else, but I don’t remember if it was turning something in as well.

Thank you for the info, if it happens again try to note what you did in the interim, and also if you can send in a bug report we can try to debug your character on our side as well using that state so it could help us figure out the issue.

For the woods one, when you say it finished do you mean that it jumped from 4 to 8 immediately, or that you had to go pick them up again to finish it?

1 Like

It jumped. I was in HS and saw the message popping up for both quests when I turned the other one in.

I also did the first outpost quest to collect the 8 wood stacks on my alt. The first 3 registered properly but after that didnt on the next. I relogged and I dont think the wood had respawned yet so I continued searching.

I found the next piece of wood and usually i would grab it and put it behind my back and let go as if grabbing a loot bag but this time I instead just held it infront of me until it dissappeared and thats when the journal updated. In this case it might not have been registering until the final second?

I hold all quest items like this until they disappear :wink: … however, this wood-thing was special, at some point there were no more in the entire zone and that was when I relogged. However, I did 2 more “rounds”, picking all of them up, relogged again and still nothing registered apart from the 4 initial.

The other quest could’ve been the one with Scavs, Buckets or Bucklers, also in rainforest, it suddenly stopped counting mobs and popped up as finished much later in another area, while doing something else.

Did any of you guys restart the game though? Relogging used to completely reset character in Oldbus. But it just doesn’t anymore now. So some problems relogging isn’t the fix but restarting is.

I had that problem with an early lore quest. I had to kill some salt thiefs and collect the dropped items.
The items where dropped normal, but the kill counter wasn’t going up at all.
But after coming back a few days later the problem was solved on its own and I just had to defeat the needed ammount of enemies. In the meantime I didn’t do anything special - maybe fish a bit.

We appreciate the info from you all. Another question if you can remember - what’s the earliest date this type of issue happened to you? Was it like a month ago? Two weeks ago? since the last major patch? That’d help narrow it down.

Thanks!

Inside the last two weeks, did not notice it earlier

I think around the 3rd week of the winter festival i was doing the kill quest on my alt in lamavora for the festival questline and it happened there. Thats the earliest I can remember.

On my main, I did the festival roughly 2 days after it was out and didnt have any issues so possible an update after introduced the bug?