Missing main Quest, Forest Secrets

gameplay

#1

I did “A Demanding Chef II” with a group of friends and turned it in. I became a little lost since there didn’t appear to be any further quests. Online research tells me I should have gotten the “Forest Secrets” quest when I got the item for the Chef quest. I don’t remember if I picked up the truffle myself or just got credit from the group…

Char: Akiroth


#2

Check your journal. Do you have “A Demanding Chef II” or “Forest Secrets” in there? Or both? This makes it easier to find out what you are missing currently.

In case you want to check what you might miss, here is an explanation of the activities of both quests:

A Demanding Chef II

To finish “A Demanding Chef II” you have to gather the red truffle in the bandit camp at the “green lady forest”. Using your pickaxe on the the red truffle in the camp. Did you remember doing that? You can not get the credit for collection the truffle as a group. You need to collect the truffle yourself. Than bring the truffle back to the chef and you should be done with that quest.

Forest Secrets

To do the “Forest Secrets” quest, you will get a pop-up of the start of the quest by walking into the “green lady forest” but only if you are on the “A Demanding Chef II” ATM. From there you have to find an item on the table of the same bandit camp from the “A Demanding Chef II” and you have to pick it up. Then you get the message that you have to inform Bishop Roma. You can find him (and the guard you actually have to talk to first) in Highsteppe. But only after you collected the item from the table in the bandit camp.


#3

I have neither in my journal. I had completed ‘A Demanding Chef II’ and turned it in but apparently never got ‘Forest Secrets’.


#4

Did you harvest the red truffle before starting the Demanding Chef 2 (while it was invisible), this seems to be the common reason why this quest bugs out, as you need a specific quest flag enabled when you enter the Green Lady Forest to trigger the next quest of Forest Secrets being added to your journal.


#5

No. I don’t believe I was even in the area before I was on the Chef 2 quest. I was in a group with some friends when I did the quest but not sure how that would mess it up.


#6

That was a week ago. Once I realized that I was missing the Forest quest (yesterday) I went back to see if I was missing something but no luck.


#7

Have you tried picking up the item from the table at the camp? If that doesn’t work either than I think @Riley_D has to fix it manually when he has the time to do it.


#8

I have tried and nothing happens.


#9

In fact, we all tried when we first got over there while on the Chef 2 quest as well. I don’t know if any of the others are having this issue with the missing quest though.


#10

Gildwick was another party member that didn’t get the quest.


#11

were you guys playing on the Beta or the Main branch?


#12

Not sure what you mean so probably main.