Mounts summoning bug


#1

I got my mount; equiped it and it worked; then after a while i could not put the mount away; i entered combat and I could not get my mount out again; i unequiped and re equiped the mount several times.


#2

Do you still have the mount “buff”? Does logging in and out fix it?


#3

Have not tried and decided to get off so I have no idea.


#4

Okay if it happens again please let us know if you still have the “speed buff” when you are unable to summon it.


#5

Yes but only if its when the mount is out; if I cannot summon the mount while off it I don’t get the speed buff; also relogging does fix it.


#6

Found why it happens; if you put your off hand behind your head and click your grip you wont be able to summon the mount.


#7

Is that still happening to you as of this morning’s patch from about 4-5 hours ago?


#8

I found it out yesterday when someone else told me the reason; have no idea after the patch.


#9

Okay cool, thanks. That’s what we thought the cause was and fixed it in the patch, so let me know if it’s still happening.