Problem with transaction on DLC for oculus quest


I’m having trouble getting the DLC. I clicked on it, then hit the check and it took me to the oculus home screen where I then put in my PIN number to purchase the DLC, after that I went back to see if It had worked and it did not say that it had been purchased, it just said that it’s $9.99. I tried again, and because I already put in my pin, there was a buffering bar, which then took me back to the game.

I still don’t have the DLC for some reason. Not sure if it is just an oculus quest issue players are having. Can anyone help me out please. Thank you!

Hi, this is a rare bug with Oculus where it doesn’t immediately register your purchase rarely the first time- normally, when you try to purchase it again, it won’t let you but it should register it properly that second time. Are you sure if you restart the game and go talk to the NPC near the Cenn’s house (the critter capture NPC) you haven’t unlocked the quest?

If that’s the case we can investigate further. Let me know.

It usually tells me that when I get back on. I Can check. Also the amount of times I tried purchasing it when that error happened, I’m hoping it doesn’t purchase it several times. Like $10 turns into $60. It shouldn’t, I didn’t get any notification about.

It won’t let you purchase items more than once, so that shouldn’t be an issue.


Also I just brought the game back up and it still says $9.99

Would uninstalling and reinstalling fix it?

What happens if you try and click to purchase it again? It should just start loading the page and then unlock the content instead of going to the purchase thing.

What happens when I click the dlc then hit the check is it takes To the oculus home screen where I’d put my pin, but it doesn’t show up, because I already did that. Instead, it give me a buffering bar and then quickly sends me back to orbus where I started from in the beginning

Okay, so we might have to unlock it manually. I’ll pass the message to the team and we’ll take a look.

Can you let me know your character name?

Yes, it is Halëm

Thank you so much

If the money does not come through for some reason, is there a place that I could just donate $9.99 to the orbus co?

I let the team know, and we should be able to give you an update sometimes on Monday. Thank you for your patience.

1 Like

Sounds good, thank you!

Okay, we found the issue - we have pushed out a new version of the game with the fix, so download that and then try purchasing the entry again and it should unlock it for you properly this time.

Let me know if that doesn’t work.

When you mean download, do you mean reinstall?

Where can I get this download?

It likely will just be an update. You likely won’t need to reinstall the game.

Hey! Good news! It worked! Thank you so much! @Mathieu_D /@KatVet

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.