Stuck, died and no graveyard!


#1

I was out Exploring and entered a lovely field of flowers but got a bit to close to what looked like a troll with a staff. Needless to say I died with 1 strike. I pressed the button that should take me to a graveyard and nothing happened - I just came alive again on the same spot then instantly died again as troll was still there. I tried logging out that didn’t help. I re-checked my settings but all was right. I even tried pressing the button moving a step so I could slowly die but move slowly out of the area but it kept respawning me back down by the enemy. Can someone please help! I don’t want to have to start all over again and work my way back with a new character. Many thanks Lexiee


#2

Sounds like you entered Lamavora from guild city.
Might want to ask @Riley_D to move your character.
If you ask in discord im sure someone would pop over to kill it for you.


#3

DIscord?? Sorry what’s that? I’m really new to all this so sorry for sounding stupid. Probably why I ventured somewhere I shouldn’t have yet till I was I lot more powerful :rofl::joy:


#4

How rude I didn’t even say thank you to you Gix for replying - so THANK YOU


#5

Hey there, sorry for the issue - I’ve tried teleporting your character back to your house, let me know if you’re good now. If you were logged it at the time I would need to do it again once you are logged out, so let me know if that’s the case.


#6

@Mathieu_D thank so much it worked! I thought I’d be out the game for days so thanks for an amazingly quick reply :+1:t2::+1:t2:


#7

No problem, welcome to Orbus!


#8

Just to answer your Discord question, Discord is a voice/text chat platform that most players use to coordinate group activities and get help with quests and stuff. You can either install a program on your computer, or use it through a web browser. Here’s a link to the Unofficial Orbus Discord:


#9

i had the same issue in reborn the waste land at to grave yard spawn killed i had to find a de agro point after i made it home