Teleported by player and now stuck


#1

Hello, I’m hoping that you can help me get back to the starting area. Basically I was stood near the training dummies and randomly got teleported to a tropical area I clearly aren’t supposed to be at as I get one-shot. I’ve tried to walk back to the starting area and the area I believe is the correct path back is too crowded with enemies for me to be able to get by without getting spotted (as in the terrain isn’t wide enough so I literally can’t sneak by).

I have tried to teleport into my home and then to go back out that way- however I just return to the area I teleported from which I’m sure isn’t intended otherwise the teleport becomes useless as a means of travel.


#2

I should have probably mentioned, sorry- my character name is UmbraSolcast

Thanks!


#3

Do you have your teleport device? If you do just equip it on your belt and grab it with your hand. that will teleport you back to your house.


#4

That’s what I did initially- as mentioned when I left my home it put me back into the high-level area


#5

That sucks, I would try using it again, once the 25 minutes has passed. Hopefully it won’t do it again, definitely report that bug.


#6

Have you tried relogging? Surprisingly it fixes quite a few issues

Edit: this is because occasionally players can get desynced from the server and funky stuff like this can happen


#7

sorry, can’t get into the game atm to help. Assuming you are in a graveyard at the moment? If not, use Return to Graveyard in your settings. Then try the Teleport Device.

Otherwise,
If you were troll ported to the Tigers(which is where many grievers use) then going to graveyard should put you into New Kingsport.
Look around for a long set of stairs, you can use the stairs to get on the airship, which will take you to Highsteppe(after a few stops).
The same direction as the stairs, is Highsteppe if you want to run, go past the stairs and turn left at the crossroads, should be few/no mobs between you and Highsteppe that way.

If you are at the Blue Worm Temple(looks like a pyramid) Graveyard is in a small town, Repair girl is right next to the graveyard. Then I’m sorry, I’m not sure of a good way out of there for a low-level player without your teleport device. If the previous suggestions aren’t working, then you’ll need to wait for a helpful player or a dev :frowning:

Did you know, you can report Troll Porters, it’s not considered acceptable gameplay to do what was done to you.


#8

Unfortunately I won’t be able to get back on till tomorrow, hence why I asked about a solution here before trying a relog. I would have spend a while longer trying other ways to get back if I had the time to do so today also.

I wasn’t aware that using the return to graveyard would get me to a different location, I thought it just took you to the nearest respawn point? I didn’t try that as I’d assumed that after dying and respawning where I ended up that it would just send me there.

I wish I’d seen the person who teleported me too, I was stood by the dummies with someone who was struggling to cast, tracing the spells for them to copy so it took me by surprise. Unless it was the player who I was helping- in which case well played


#9

Sorry for the inconvenience. The teleport device definitely isn’t supposed to work like that. It’s definitely odd that it did. I’ll forward this along and see what we can do to help you out.


#10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.