Thunder noise needs change


I love the different weather cycles of the game, with the day night cycle, from sunny to downpour, i don’t even mind the thunderstorm. But for the love of god can you turn down the thunder, it feels so out of place from the night peaceful land, and i had to turn off the game due to it just being immersion breaking and obnoxious. I know there is a volume control in the settings, but i believe i am not the only one feeling this way about the sound and how loud it is.

I suggest turning down the sound as it does add a nice aspect to the weather pattern, but its WAY to god damn loud :slight_smile:


It immerses you in the middle of a thunderstorm pretty well.

But yeah the first time I heard it the thunder sound made me jump


I feel like the thunder volume has already been turned down significantly. Or I may just be used to it.


Back in beta we had no volume slider for weather effects so the thunder used to blow our ears off!


Also, the “body lamp light” (don’t think I got the name right) potion is insanely loud. I put it on in a dungeon and could not hear other people in the group, lol.


Yes, please turn down the volume of “body lamp light” about 20%ish by default.


I kinda like it when it scares the (*#$ out of me. I live in Florida and I can confirm its 100% realistic :smiley:


I would really like to see the volume of Thunder turned down. It doesn’t make me feel like I’m in a thunderstorm. It takes me out of the game and thinking “man I should stop playing and post something.” Now I’m here.
I’ll most likely just wait 30 minutes before playing so hopefully the weather has changed. I can’t hear anyone in my party when it happens.


Off hand, I’m not sure which setting it is, but you can turn down the volume on the weather using the ambiance(I think) slider.
lol, I think I actually ducked irl the first time I heard thunder :joy:


I think it’s too loud too. Maybe the first lightning bolt at that level is okay, but after that it really should be lower, or variable. I don’t want to turn every ambient noise down just because of one thing that hurts my ears.


Just add a thunder slider haha


We’re tracking this issue. Thanks for reporting.