Trouble with mage teleport

I feel like I’m missing something. I successfully cast a portal spell, the pedestal comes up, I grab the ball, and nothing happens. What am I missing?

Four questions:

  1. Where are you?

  2. where are you going?

  3. Are you putting ball to your face?

  4. Do you have pvp on?

I’ve tried it from a number of places and tried going to a number places. Mostly trying to get to guild city to by a potion of forgetfulness to respect one of my toons.

I’m lvl 13.

Did not try brining to face - will try that. Didn’t think I would need to do that as my teleport to my house doesn’t require it.

I’ve never done PVP, so don’t thing that would be on, but I’ll check.

Bring the ball to your face. Also guild city is the raid now. I believe your using old game information.

Ah. Perhaps. So, where can I get a potion of forgetfulness - or is there another way to respect my talents?

Odds and ends in highsteppe basement


Hi, it’s definitely possible if you’re going on old information you’re trying to use a teleport spell that doesn’t lead anywhere anymore.

You can find the current ones here if you don’t mind some spoilers:

You also need a runemage reagent everytime you teleport.

Ah - this is very helpful. Thank you.

Casting valid runes to an invalid route will just cancel the spell without consuming a reagent. He wasn’t bringing it to his face.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.