Extremely high latency in-game

while playing both wifi and ethernet, i have extremely high latency (1500+) while doing anything in game. When i do ping -t game-direct.orbusvr.com, i am not losing any packets and my ping is constantly 50-60ms over time with no wild fluctuations. I live in arkansas, usa

As i post this, am still trying things out and if i find any solution ill update the main post.

Are you in Highsteppe right now? It’s possible it’s just super busy there. Try going into the Tutorial Area or your Player House and see if you are still getting latency notices there.

i am still in the first area after creating a character and have been testing my latency in the first available player house. the high latency thing doesnt pop up until i make some kind of physics interation or something, like throwing my gun turret or dropping my pick. also combat does it.

So if you’re inside the Player House and then throw your gun turret it happens?

(Also the first area after creating your character if you see a bunch of people running around is Highsteppe).

i just noticed that the latency isnt actually triggered by anything, it just happen to show up at the same time I threw the turret. It appears about 5-6 seconds after loading into the game, and stays with me

also, thanks for these lightning fast replies!

Oh okay, well it’s normal to see that latency notice when the game first loads or if you move between zones. Have you tried waiting around for like 2 or 3 minutes in the Player House to see if it goes away?

Are you actually experiencing lag? Try getting out your sword and swinging at a Practice Dummy outside the house. Is there like a 2 second gap between when you strike the dummy and when the explosion appears?

yes, the lag is there consistantly. When i first played, i thought the game was just buggy and took a break for a couple days, but apon playing today I happen to notice the latency above my xp bar. When i try to fight things, there is a long delay after i swing my weapon to the time the numbers show up or the npc responds to my hit

Okay, good to know. That’s very strange.

A couple of things:

  1. What are the specs on your computer (CPU/GPU/Memory/headset)?

  2. Can you send me your output_log.txt file to riley@orbusvr.com? You’ll find it in your (SteamLibraryFolder)/steamapps/common/OrbusVR/vrclient_Data/output_log.txt

  3. I know you said in your original post you have tried both ethernet and Wifi, but are you playing on Wifi or ethernet right now?

Let’s start with that and then maybe it will spark an idea on my end as to what’s going on haha.

playing on a gtx 970
Intel® Core™ i7-6700 CPU @ 3.40GHz (8 CPUs), ~3.4GHz
16gb ram
htc vive

my net speed(currently on wifi): http://www.speedtest.net/result/6948482390

sending my output log shortly, thanks!

Okay, so I definitely see something wrong. In your output log, for some reason the game is trying to like connect twice? To two different client hosts?

It’s not possible you have two copies of the game running somehow is it?

if i am running two copies, its definatly not intentional. i am double clicking the orbusvr icon on my desktop to play the game. also, when i alt-tab i only see one copy of the game running

Okay…yeah that’s just very strange. I have never seen this before.

Is there anything else you are doing when teh game is first starting up? Are both of your controllers on? And you’re just tapping the Login icon once? (You shouldn’t be able to tap it twice but just making sure haha).

If you can’t think of anything I will see if I can put some code in to fix the problem, just may take a bit.

at first i was making sure everything was on and ready, but ive restarted the game so many times that ive gotten lazy and have just been turning on one controller to login.

Im about to load into steamvr’s home thing, and launch the game after ive already loaded steamvr to see if that has any impact. Will also do some stuff for a few mins then maybe send you another log?

Sure sounds good. Might try just fully restarting your computer too just to be sure there isn’t something weird going on.

sent the second log, restart my computer and will try some more gameplay. if anything changes ill let you know!

Okay so two things if you’re still having trouble:

  1. I put some new code in a new build that I think should prevent that issue from happening. Right-click on OrbusVR in your Steam library, and choose Properties… then in the “Betas” tab at the top, choose the “experimental” build from the drop-down. It should update your game.

  2. I noticed you are on NVidia Drivers 375.63 – those are from October 2016. I don’t know if it’s related, but can you update your drivers and see if that helps at all? Also which version of Windows are you on? There is an error in the log about being unable to create a vertex shader that shouldn’t be happening, either.

working on all the above now, sorry for the delay! also, am on windows 10 home edition

No worries I’ll be going to bed in a bit, I’ll check in with you in the morning though!

For Riley and anyone else reading this post, my latency was lowered tremendously with these fixes. will keep this topic updated if anything changes between now and tomorrow. Am running the experemental build now with latest video drivers

ps, thanks for the amazing 1 on 1 support! without it, i would have gone to bed sad that i didnt get to experience this amazing game the way it was ment to be played

Awesome glad to hear it! And you’re welcome!