Fix inability to move with wand in hand on SteamVR

Currently, if you play mage with steamVR, all movement input is ignored from your wand hand when you have it equipped.(you can still move with your off-hand) This was implemented way back when the vive wands we’re pretty much the only steamVR controllers since it had less inputs than the standard VR controller nowadays, with the trackpad being used both for movement and casting spells.

For me I use my right hand to rotate, which is not possible with my wand equipped if I play through steamVR. While on meta I can rotate as one would expect, this was particularly annoying when I first went from my oculus rift to the valve index.

Now of course there could still be some people who use the vive wands with orbus, so a fix would need to still keep the block in place, but only for those using vive wands, which I’m pretty sure you can get that info from the steamVR unity plugin.


Isn’t this an issue with the Quest too? I hate having to use my left hand to teleport to avoid a smash. I always get hit as a Runemage since I can’t remember to teleport with my off-hand xD

That’s teleport, you can’t teleport with your wand hand because you use the same button for casting spells. On steamVR you can’t even slide around or snap/smooth turn with your wand hand, this you can do on meta/oculus.

I don’t have a working steam headset at the moment but I’ll definitely take a look once I get my hands on one


This also happens if you launch the game on a quest headset with steamvr open.

Just having steamvr open launches orbus side-by-side with steamvr, without actually using steamVR. In order to run orbus through steamvr you need to open the games properties on steam and enter “-vrmode openvr” in the launch options field. Then orbus will run through steamvr on an oculus/meta headset