Glitched lighthouse quest

Hi there, I have a glitched quest. The Lighthouse one where you need to talk to the Shipping Master for him to give you the materials that the lighthouse needs.

It worked for my boyfriend - he talked to the Shipping Master, and got most of the materials. For me, nothing. I wave and wave and he won’t talk to me. I definitely have the quest. I’ve tried logging out, restarting, going back after several days. Nothing.

I even got a different quest with him, and he spoke to me about that one when I waved at him later, but he still won’t speak to me about the Lighthouse quest.

What to do? Is there any way to drop a quest and pick it up again - to start fresh in a way?

Thanks much,
Sandra

Hi, do you have any other quests that involve the NPC? From what I recall, the MSQ quest lines do occasionally involve him.

Sometimes there’s an issue where if you are currently on a quest which requires you to speak to an NPC once it needs to be turned in, you need to complete the first quest before you can progress on the second.

Let us know if that helps.

1 Like

Ok, I checked, and I have no other quests in the journal for him. However, when I first picked up the lighthouse quest, I did. I had the chickens for the farmer lady, and the Othaman Pickaxe. I was able to complete both of those, so nothing left now but the lighthouse one.

Hang on, I think he said come back and check with me later. Is that enough to block the lighthouse quest?

Thanks,
Sandra

If you have no other quests in your journal besides the lighthouse one that shouldn’t be the issue.
Can you let me know your character name? We can take a look at its data and see if we find something that is off.

Ya, I went back again just to show you what I get when I go. He seems to have no idea I’m on the Lighthouse quest.

My character is Valla. Thanks much!

Hi, any luck? My character is Valla. Thanks!

Hi, thank you for your patience, sorry for the delay. We went through your character data, but it doesn’t show you having the lighthouse quests at all. Is it still displayed in your journal, and if so which one is it?

Can you try speaking to Arlo again and seeing if that does anything to progress or grant the quest?

If not, we can try and give you a quest flag manually and see if that will get it unstuck.

and how come you can’t look up this data if i may be so bold to ask? I assume this data is either kept server side, or client side with server side updating.

Edit:
Furthermore, i assume it ought to be a trivial task to make a copy of Valla’s account with a different name and then test the relevant parts much faster than going back and forth :slight_smile:
But of course, i am basing this on assumptions which makes… something something :slight_smile:

Yup, it’s definitely still in my journal.

And Arlo doesn’t speak to me. Would be nice to be able to drop a quest and pick it up again.

I stopped carrying all the quest items around in my bags, but I wasn’t able to speak to the Shipping Master even when I had them all in my bag.

Thanks,
Sandra

1 Like

Hi, any luck? Can we just remove the quest from my log please? Then I can pick it up fresh from Arlo… thanks!

I apologize for the wait, we should be able to grant you the quest flag shortly, it’s on our to-do list and hopefully that should solve the issue for you. I’ll let you know when that is done.

Okay, the objective of talking to the shipping master should be completed now, so you should be able to grab those items you had and complete the quest.

Ok cool, I’ll try today! Thanks!

Hey, sorry I forgot to come back to confirm. YES, that did the trick, and I was able to progress the quest chain. Thanks!

2 Likes