MSQ Help - Lost Amulet I

Hi fellows,

is it possible to give me an hint with the MSQ Lost Amulet I. I was in the Library and found the Frostrune book but after this I can’t find any clue. English is not my native language, so maybe there is a hint the the text on page 3, but not possible for me to understand :frowning:

Thanks for your help

This seems to require an Ithecac-Potion you can buy from one of the quest givers or perhaps already in the auction house.
And I read Ithecac does not work yet, but did not try myself.

Ah ok. I’ve tried already the Potion. So I was on the right quest path :smiley: thanks

Ithecac Potion costs 1000 Dram and you can buy it from Darius

pay attention to the capitalization on the last page of the book you found


I’ve solved the puzzle, but I think that’s too difficult for the main story.

And to have not the possibility to write something down in the game, it makes it even harder as you confusing the puzzle with additional captions.

Nerf it a little bit. Maybe the unnecessary captions.

Nah, puzzle was easy, problem is ITHECAC won’t do anything even if I’m in the



This is a bug were tracking down, if you take more theb one ithecac without relogging tge second one wont show the proper items.

Ah, the I chugged 4 and suddenly it worked. Still no drug effects

The screen effects are not in for the effects but the showing of objects works

1 Like

is this still an issue. took the potion , had some odd color effects but the books look normal

No this should be working properly, are you having trouble grabbing the item, or it not appearing?

is the Item in the


Basement of the Player Housing

I didnt see it there if it was

Yes it is, its possible the bug came back where if you drank more then 1 ithecac potion while logged in then its not showing properly. Well do some testing on our side and see if this is the case and we can reproduce it. If you log out of the game in the right spot then log back in and take a potion you should see it, sorry about the issues.

Its all good thanks for the update

just a heads up i was able to find it after i drank the potion in the area :grin:

okay cool, ive added it to our list to double check and work on, but im glad you were able to continue.

i was probably having the same
problem with not seeing any items in the location the hints gave me. i will try again but i’d already given up and was just waiting for someone to write a walkthrough lol