Original Sicilus dragon, no stats, can't breed


#1

Hi!
I just finally tried dragon breeding today.
Previously I’ve only had the Sicilus dragon from back in January.
I read in the wiki that “Dragons acquired from the Backer tiers of Kickstarter, and Sicilus Beastiary quests can still be used in Dragon Breeding. The first time they are placed in the terrarium they will be assigned traits. These traits will not match the outward appearance of the dragon.”
So I placed him in, closed the lid on the chest, stepped back, then retrieved him. His tooltip didn’t change; still just says Pet with no stats displayed.
Logged out and back in, same.

Bought a tiger dragon from the Zoological gardens. Made sure new dragon was happy with a treat. Fed my original dragon again too.
Put them both in the terrarium, no flame.
Tinkered in my home for a bit, brewed some potions, no change.
Went back to the Zoological gardens and splurged half of my dram to buy a sea dragon.
Came home, fed him, put him in with the new tiger dragon – ah ha, the flame of love!

Started searching the forum, didn’t find anything quite the same. Did find this post from April which at the end has some talk of the Sicilus and Kickstarter dragons having an issue that should have been fixed with a patch around that time.
I think my dragon might be antisocial? :wink:


#2

Is he playful? Happy is irrelevant


#3

Playful is the status that appeared on the 2 purchased dragons after feeding them a treat, as expected.
I had no issues with the 2 purchased-yesterday dragons mating. When I wrote “Made sure new dragon was happy with a treat.” it was a turn of phrase, I wasn’t indicating its status, which was indeed Playful.


#4

The reason I’m asking is because trait dragons have a secondary stat that can be happy, and some candies only effect that stat.

Ok, if your starting Dragon is playful and the dragons are placed in the first two slots, we should probably summon @Riley_D (spell chanted)


#5

Well the 2 I purchased yesterday from the Dragon Shop NPC act fine, and overnight mated and gave me a new dragon, who I’ve now forced into breeding servitude. :wink:

It’s my original dragon from Sicilus who is the problem, as he has no stats even after putting him in the chest for a moment and pulling him back out. He didn’t convert from original pet item to new breedable pet item (no database update I guess).

I figure Riley is pretty busy with the beta stuff right now. =)


#6

Helpful screenshot of my situation, fwiw:


#7

We will take a look at your inventory tomorrow and hopefully fix the problem.

(Pinging @kyle_l so I don’t forget haha)


#8

Oh, thank you!
No rush, I’m sure you’re busy busy sort through the weekend’s beta testing logs. =)


#9

Would you be so kind as to look into the inventory of my close friend, Delco, too please?
He and I bought out Sicilus pets at the same time and tonight I showed him the dragon breed system, and his original dragon also did not convert to having stats after being placed in the terrarium chest.


#10

Ok, I found the problem and made a fix. Riley just has to decide when to restart the server to apply it. Basically if your “legacy” pet was given a bonus type before being put into the breeding station, the station assumed the pet had data to breed even though the pet didn’t, so things broke from there. Your pet in particular doesn’t have a bonus type, but at some point a bonus type of ‘nothing’ was applied to it that caused the issue. That fix should get pushed out by the end of the day, and I’ll ping this thread when it does.


#11

Thanks for the explanation – I always find that fascinating.
Thanks for helping me!


#12

No problem. If you haven’t been in your player house, it should be fixed for you.


#13

I just logged off a several-hour gameplay session in Orbus and wanted to say thank you – the fix worked! =)