OVRdrop and OrbusVR doesn't seem to play nice (help - using Rift)


#1

So I just bought OVRdrop, opened and set twitch chat for window and left - behind controller yadayada and loaded it? don’t know if I need to do that but.

I open OrbusVR afterwards and it doesn’t show in-game, but when I swap over to desktop and stuff it shows up.

Tried running compatibility mode - win7 with OrbusVR but that hid it from my tabs in the oculus menu, rendering me unable to reposition my view, so I’m unable to play because I’m always all over the place except for infront of the login menu, but that did make me able to view the twitch chat in-game.

Tried the same thing with OVRdrop, running it in compatability mode with win7, what do you know, same issue there, it disappears from the oculus menu tabs, and does not show up in game after I stopped running OrbusVR with compatability mode with win7, but then it showed up in the menu again and I could reposition view, kind of at a loss.

Any more nifty tips n’ tricks?

EDIT: Running win10 64bit, both applications in steam


#2

You might have to upgrade to Windows 10


#3

Currently using win10 @Rickness_Voidwalker ^^


#4

Hmm okay, I’ve not used OVRdrop, I normally use Oculus dash and pin the window to the virtual space, have you had any issues with that seeing as you’re on oculus rift?


#5

@Rickness_Voidwalker Haven’t tried anything but OVRdrop yet since it provides some nice functionality I haven’t seen in other applications, guess I’ll have to give Oculus dash a go


#6

If you go into the settings and to experimental (I think) you can turn on a setting to pull a window out by holding “A” and then using the grip to pull it out, if You pop out your twitch chat window you should be able to just pin that and move it where you want it, like in front of you in the air/on the ground or whatever


#7

So what I thought the issue was, that orbusvr, even if bought and opened on steamvr, uses the oculus sdk…
so that OVRdrop doesn’t show.
Running OrbusVR in win7 compatibility mode and a lot of playing around with settings has made me able to finally make it “playable” with OVRdrop working (due to oculus sdk not running with win7)… however I now have no sound in-game and visual artifacts + some frame drops. (which I don’t think should happen with a i7 8086k and a overclocked 1080ti running at ~65 celcius with no supersampling in OrbusVR? Wasn’t a issue before I started fiddling with win7 compatability mode atleast.)

Was wondering if anyone knows of a way to disable the oculus sdk from interfering other than using win7 compatibility mode now that I’ve more or less confirmed the issue? ^^

Just took me 8 hours wooh! haha, only had a vr headset for a few days


#8

if you right click the game in steam and go to properties at the bottom. then in the general tab you click set launch options and you’ll get a little window where you can input some text. write “-vrmode openvr” and it will force it to run through steamVR, but I would recommend writing “-vrmode oculus” instead and use the oculus SDK. like rickness said oculus dash in experimental mode has some neat window pullout features that should also work for your twitch chat.


#9

Though if you want to hide the twitch chat you have to open the oculus menu and then unpin the window, otherwise it will stay in the world and can hide things from vision. If you want to do twitch chat I would recommend OVRdrop due to the ability to hide the chat on the fly by rotating your hands back to the regular resting position and checking twitch chat by rotating the back of your hand towards you. Its much less obtuse from the oculus dash in experimental mode. You can do whatever you want @Sturla_M however if you do choose to use -vrmode openvr the game will use the vive position for the hands so you will have to get use to the hands again. It did not take me long however due to using -vrmode openvr.


#10

So I tried adding launch option -vrmode openvr and OVRdrop worked, but brought some new issues, getting used to hand placement was ok, but I had to reduce graphics to low due to unstable frame rate bouncing between 45-90, I have asw disabled in the oculus debug tool, with the new launch option I guess I’m not using that anymore, so any way to turn asw off with the new launch code? (Almost certain that has to be the problem due to it bouncing just between those two numbers? could be wrong) Also, lost tracking every now and then for some reason, and having my head suddenly flying around was a new experience haha (motion sickness lets go!).

And @Asmund_T , @Richleth , and Rickness_Voidwalker Thank you ! (can only mention 2 users per post:() Slowly but surely learning a bit more


#11

Try disabling motion smoothing in the video tab when using the computer and try to look for all the reprojections in the steamvr settings (while in the headset) and turn them off, that might fix it.


#12

still wondering why you don’t try oculus dash. :thinking:
I know you bought OVRDrop and don’t want to waste that but… You should really try it to save yourself some trouble.


#13

I guess you could say it’s a valid arguement, but I feel like having a window set open is intrusive to the experience, which is where OVRdrop shines, it can be gone until I want it to appear without having to fiddle with stuff, for now setting up oculus dash until I get OVRdrop to work anyways ^^


closed #14

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.