Paladin Hammer Teleport

So I spent nearly 30 minutes today trying to activate the paladin’s hammer teleport ability. I am playing with the oculus rift original version, using the oculus touch controls. The game tooltips, as well as anyone I have asked all say the same thing "throw the hammer and press the trigger button to teleport to it. First of all, YES, I do know which button is the trigger button (even googled it to make sure I’m not a complete moron, only partial). When I click the trigger button it instantly ports the hammer back to me, instead of me to it. The grip button slowly makes it travel back to me. I have tried it at 0 charges, 5 charges, and everywhere in between but always to the same result. I have tried in many different locations, tried activating the teleport ability with the hammer and hundreds of different heights/angles/distance from me and always the same result, the hammer porting back into my hand…

Is there something I am missing here?

It doesn’t work in most of the city of Highsteppe. You’ve got to be out and about for the most part.