Treasure map bug please fix!

I have done several treasure maps now with no problems, i did all of them that i got as a drop no problem at all, but the first one i bought from the auction house bugs out and i cant open the chest :frowning: no matter what i do i cant open the chest, i tried putting the map on the chest so many times, i tried everything logging out taking the map off putting it back on, i think it has something to do with me buying it from the auction house, there is no vibration on the chest when i put the map on it, but it does disappear and reappear as i take the map off and put it back on

Is it expired?

here are some pictures

and i know your thinking, the map isnt on the chest trust me i tried and tried for like 10 mins tried everything

The map could of expired. Alot of them expire while sitting in the auction house

oh wow its expired, i just bought it for 20k like 30 mins ago… what good does an expired one do, F$#@ lol

1 Like

devs please make expired maps remove from the auction house, also please add in a slot for trickster tokens, and trickster goblin tokens on the auction house on a side note

1 Like

You can see the time left in the auction house

1 Like

It’s kind of on you to check how much time is left

1 Like

Maybe update the icon upon expiring