Unable to use joystick on HP Reverb G2 controllers

So, as the title says I’m unable to use the g2’s joystick to move around which I really a deal-breaker for me because it breaks immersion too much to solely teleport around. Anyway, I’ve spent the past hour or two looking into and researching this issue and trying to fix the binds and making sure all my settings were set up correctly but nothing ended up fixing it. Does anyone else have any suggestions?

1 Like

Hi, I don’t believe anyone on the team is familiar with the headset so it’s not officially supported, but if it can use Steam Community Bindings, then you may be able to pick one and have it work. I would give that a shot.

Unpair them in the Windows devices (left and right controller) and then re-pair them while in the HP reverb app under setup controllers.

Then in steam change your per-game controller config from default to Disable Steam input and restart steam and finally go back to the per-game controller config and Enable steam input and you should be golden…

It sounds like a lot but it’s quick and you should only have to do it once.

If you have trouble with or after that check this out: https://steamcommunity.com/sharedfiles/filedetails/?id=1545634111

1 Like

this seems not to work dfor me, anyone got this working?

When SteamVR is open click the 3 lines in the Steam VR window and find “Devices”

Try pairing them there instead of in the G2 app… but, if you are also playing games from the Oculus store you might have trouble. If that is the case and the pairing thru the g2 app failed then I’d suggest going to “Controller Setting” found under the same “Devices” menu and rebinding the controller to suit your desire.

It is important to unpair from Windows Devices first if you are paired there.

can you tell me where to find the controllers e
xactly in windows devices. I can’t find them :see_no_evil:

I’m thinking that you mean in device manager, am I right?

Yessir.

Settings > Devices > Bluetooth & other Devices

You want to unpair them there before you re-pair them anywhere else. Prolly should reboot after unpairing them also… just in case…

Pairing thru the G2 app should make them work with both Steam and Oculus as well as any compatible Windows Applications…so I would try that first… but if for some reason that doesn’t give you the results you want, then pairing directly to Steam or setting up new bindings definitely should… but if you pair directly to Steam you will probably run into similar problems to those you are experiencing now when using some Oculus software.

Unpairing them from Windows and re-pairing them in the G2 app while steam is open an then disabling Steam Input, restarting Steam and then re-enabling Steam input should work…

If not, and if you don’t use Oculus or WMR pairing directly to Steam should get you to 5x5…

If you do use Oculus and WMR stuff tho, and you are sure that pairing thru the g2 app doesn’t work as you want it to…then rebinding is the only suggestion I can offer.

Everything there is to know about that process is here: Steam Community :: Guide :: Rebinding "Legacy" games for new controllers

Good luck!! :slight_smile:

First of all, Thank you for trying to help me out so much!

And then, in my bluetooth settings I only see my vr headset under audio. No separate controllers

You are welcome. I am happy to try and help! :slight_smile:
If they don’t show then they aren’t paired to windows, so you should be good to re-pair them!

Good luck!