Upcoming Bugfixes/Dev Roadmap

Seconded. If I’m running things with other folks I have just started shutting the game down first since this does happen often

1 Like

Hi everyone, I wanted to give you an update on what we’re working on. As we explained in the original post, our next goal was to fix the desync on death, and desync when changing classes. While debugging, we found a large root issue which in fact caused both to happen the same way.

We’ve been doing a lot of testing on this, and the good news is that we were able to not only reproduce the issues on our Dev server, but also simulate and prevent it from happening. However, we have to do a lot more testing as this is a pretty fundamental change with how players load in the game.

We’re optimistic that we can get it out to you all next week, but we’ll have to do some more testing to be sure before we can roll it out.


that is amazing to hear, extremely excited


That is excellent news!


i experience a issue when I change class the weapon goes to the wrong hand I initially put it on. Also when try to put the class gear does not apply the right weapon and class items for me to fix it is to add a different class 3 time and add the class I need to use or log out and log back in should also fix to but it is very annoying issue

In regards to the audio bug, whenever it happens to me, I die and respawn and it seems to work.

Another update before the weekend: it looks like generally Tuesday’s patch fixed 99% of the two specific desyncs, however we are aware of the issue that it created with weapons being stuck on the wrong hands.

We should have a fix for that issue next week, and we’re also currently debugging stuck in combat problems though we don’t have a solid timeline for that issue yet.


I have noticed that after 15.05 my scoundrel gun will not fire on occasion when pressing the fire button on my touch controller. I can fix it by opening my equipment and swapping the gun from my right to left hand and back again, swapping to another class and back also works

1 Like

I also noticed this yesterday. So far it looks to be only an issue with scoundrel. I can get it to happen pretty reliably so hopefully we’ll have a fix for it soon.

1 Like

If you burn a card it also fixes it

1 Like

Normal mode citadel boss 4 earlier today - several of us desynced and soon as we entered the portal during red phase. Then after another attempt and successfully killing the spider group from red phase, someone desynced causing one of the pink/purple orbs to go out toward the wall. Needless to say, we never completed the boss. As far as I can tell, you haven’t fixed anything, only made things worse.

The flying ball been there since the beginning of boss 4. Nothing changed that. We been dealing with it on hardmode and found a stupid workaround for the problem after reporting does nothing :sweat_smile:.

We had a number of issues that came up in that run. In one try, we had the port close and killing everyone inside. The boss had not damaged the port.

This was yesterday Sunday, I’m not sure what is fixed.

I was doing a citadel Hardmode boss 3 Friday and i was shooting the suns in the sky but many of them were invisible to me causing adds to spawn killing the dps and we never were able to kill the boss due to these bugs. I tried to relog and close the game but nothing worked. Also I had rummage off and everyone had capes and pets off. I’m also on oculus link through my computer

1 Like

I have the same issue but I’m on pc on steam on the cv1 and I fix it but closing orbus and launching the game after fixes it

1 Like

Had an issue in Dungeon Queue today where my hammer wasn’t registering hits after I put like, three pips into the boss.

Hi everyone, we spent this week debugging the issues outlined in my last post, and we wanted to let you know what our status on these is.

We had initially hoped to push another patch this week to solve the desync where weapons are going on the wrong hand and not the one selected, as well as one where a weapon might not work (primarily scoundrel guns from our testing, but might affect others) unless you press the trigger of the other hand. Unfortunately, during testing we ran into some complications, so we have to put in more time to solve these. We are hoping to have a patch out for them next week.

We’ve also made progress on the stuck in combat issue, which we believe was tied to an old desync as well, but we have some more work to do on it before we release it since the fix touches important gameplay aspects.

We appreciate your patience and will continue to keep you up to date with our development efforts on these issues.


thanks for the update :grinning:

This might have been fixed already but when I try to switch classes in dungeon cue the symbols will stay the same but the weapon will change. For example I will have warrior shield on my ranger bow.

The symbol tells you what role you’re supposed to be playing.

If it’s a shield, you’re the Tank of the party. Sword means dps. Green plus means you’rea support. Changing class doesn’t matter; you’re supposed to be fulfilling a specific role.