Alpha Test 7 Questing--> Problems/Feedback

Let me know if any problems you are running into with questing.

Yellow ! = quest/info to be given
Yellow ? = Quest can be turned in
Grey ? = Quest in progress/not all objectives completed yet

Here is a list of all the Main story quest in game as of this test (In order)

1.Guardian Bart- Sword Training,Monster Slayer,Ranger Training,Musketeer Training,Gathering Training, Final Challenge
2.A Demanding Chef
3. A Demanding Chef (2)
4. Forest Secrets
5. Secret Tithing
6. Festival Celebration
7. Airship to University Isle
8. Job Seeker
9. A Pilgrim’s Journey
10. Pagan Magicks
11. Report for Duty
12. Woodland Rebels
13. An Unruly Outlier
14. King Sweeties
15. The Ambitious General


Rolled a new character. Few minor things I’m running into with the starter quests:

  • After collecting the queen’s ears for Bart’s harvesting step, I returned to him but got the “Please go harvest 3 queen’s ears” text instead of the turn-in text. Waving again triggered the turn-in text.

  • After talking to Old Man Cenn and getting his kill-10 quest, he still has a bright ! over his head. However, waving at him does nothing. Unclear whether I should be able to interact some more. (This is persisting through logout/login.)

ok thanks Zardulu, on the harvester when he first told you about it did you grab it right away like tool tips told you to or did you just head straight towards the plants and harvest. And on Cenn have you completed the Chefs order quest?

Found a kid outside of guild city with a quest that I was not able to talk to.

I also could not find the person on university island to talk to for the quest. Is it the girl outside?

No if you are on the “airship” quest you will talk to Bishop Roma inside the guild city, but if you look in your journal and it says you haven’t completed the “airship” quest (should say :“Bishop Roma awaits you at University Isle, return to the airship captain to secure your passage.”) then you need to go talk to Guardian Bart before leaving Highsteppe.

And I’m tracking bug with little boy by Guild City not saying anything, but thank you I forgot to take him out.

I’m on the part that says to return to the airship captain in order to secure passage to guildcity. I went to talk to Bart but he had nothing to say. Airship Captain doesn’t have anything to say and the airship didn’t go to guild city. I also before tried to just go to guild city and university island but couldn’t find the person to turn it in.

Maybe bugged it because I did the quest previous test?

Could be we could have Riley just reset the QF if you want to.

That sounds good. Thank you.

What’s your in-game name?

It is Sour. Sorry I went for a lunch break :slight_smile:

Okay, should be good to go.

Could not login with the new launcher I was hovering above my character for login.

Are you on Oculus? If so you may need to adjust your SteamVR height:

I log on and there’s no npc, players or anything. I can only see the map. I’ve been playing for 3 hours now and had no problems

Use the Return to Graveyard option in the Settings menu. Chances are you are in the wrong zone. Sorry about that.

Yup that worked, but now I’m far far away from where I was, lol. Gotta start moving!

Yeah, sorry. :slight_smile:

Now I crash pretty much non-stop. Mostly when getting attacked by mobs. (I see a loading screen with the unity logo)

But you weren’t having that issue prior? Did you just get the new patch?