Beta 6 Patch 2.95


#1

Hey everyone.

So we have a new client-side patch that is going to be available to download here in about an hour. This patch is not going out automatically to everyone, as it has some major changes to how the login system works, so I’m looking for some brave souls to test it for me to make sure that we didn’t miss any major bugs before we fully roll it out.

The patch notes:

  • Continued work to attempt to fix issues with people not appearing correctly to other players. In particular, LOD1 versions of avatars should now show correct hair/hair color/eyes/eye color/mouth.
  • Fixed mounts not resetting correctly when returned to the Player Avatar pool.
  • The login screen is now different behind-the-scenes in how it works. Essentially, now when you reach that screen you are more fully “in the game” than you were before, and therefore it should take longer to get to the login screen, but once you’re there, logging in and switching between characters should be faster.
  • Fixed some issues causing bars to show up weird on other players.
  • FIxed issues with Runemage spells getting stuck if the Mage moved out of range before the spell expired (happens frequently in Battlegrounds).
  • Power Pools (such as in Airship Boss 2) won’t keep spawning over and over again throughout the fight.

Once this is available, if you could particularly test:

  • Voice chat, especially when logging out then back in, to make sure it keeps working properly.
  • Try to get the “other people show up weird” bug to happen and if so send me a log.

That would be super helpful. I’ll update this thread when the download is available. Thanks!

Also, I wanted to make a note on something I’m not sure was every fully explained. In Reborn, one of the things we have now is an LOD system for the other players so that if someone is far away, or if they are close to you but lots of other people are around, we can do less rendering work so the game still runs smoothly. On PC, the LOD1 is the “lowest” it goes to, and this kicks in when more than 10 players are around (so the 11th farthest person for you will be LOD1). In LOD1, you still see the armor for a character, but the “morphing” of their body shape is disabled. So you will see the correct armor, hair, eyes, hair color, etc., but their body/face shape will just be the default one like how a character is on the character select screen when you first make a character. That’s because we have to use Mesh Renderers instead of Skinned Mesh Renderers which are more expensive, to save CPU processing.

Anyway, this was broken before in that the hair/eyes/other features weren’t showing correctly, but in this build that should be working, but just wanted to note if the body morphing isn’t in place that is not a bug.

Also my intent is to make it so that higher graphics settings have more players at LOD0, but that’s not in yet.


In-game font still breaking occasionally
#2

Give it about 10 minutes to finish uploading and it will be available here:

(No longer needed, this update is on the auto-update branch now.)

Note that this is a launcher that will not auto-update so once we move back to getting this out you’ll want to switch back to your existing launcher.


Battle grounds very bugged
#3

This should now be available to download. Thanks!


#4

Got this, hands working in BG’s again


#5

Voice chat working okay as well?


#6

Just got back in to a battleground with no hand again - Log sent via launcher

As far as I can tell voice chat has been okay so far…


#7

no hand here as well


#8

Other than your hand disappearing, any other issues? I assume spells aren’t getting stuck…are other players still ghosts with no heads?


#9

Mounts and headless players seem to be fixed as far as I could tell


#10

Are both you and Kamina playing Rangers? If not Kamina could you send me your output log too after it happens?


#11

I think Kamina was playing Scoundrel Paladin or Bard, don’t think I’ve seen him on ranger, I’ve just jumped off for the night now though


#12

Okay, well I see the issue for you I think but I’m just curious if it’s all the same cause or what. So I guess Kamina if you could send it in if it happens again that would be great, thanks.


#13

I actually logged out pretty much right after it happened to make food so once I get back to my computer I can send that to u

Also I believe I was a scoundrel, I think I had that bug a few times before as well, but putting away and taking out my weapon had fixed it


#14

Okay, great, thanks!


#15

That wasn’t fixing it for me :sob:


#16

Okay so in about 45 minutes this will be rolling out to everyone as an update. I’ve fixed a few more bugs around “ghosts” and also fixed an issue with logging in/out with the Websocket connection type. I also fixed the bug in Rickness’ log resulting in hands disappearing for Rangers. If that happens to anyone else after this goes out, please send me a log so I can fix it.

Note that if you downloaded the Beta launcher above, after this goes out you should switch back to the normal launcher to resume auto-updates.

Finally, in addition to the above patch notes, we’ve made a change to the Scoundrel based on feedback from players. Now when charge a bullet in the gun, it will still only use up one bullet. This should allow you to get a better rotation going where you can switch between fast-firing bullets and using up cards, and charging up bullets when you are ready to pull off a large burst of damage. This should obviously result in a substantial buff to overall DPS as well, and we’ll look at data after it comes in on this to see if we need to make some other changes (e.g. we may need to slow down overall bullet generation due to this being a DPS boost). But since Scoundrel DPS was lagging a bit and also the rotation was a bit wonky, this should help in both areas.

I’ll update this thread when the patch goes live in the regular launcher. Thanks!


#18

Patch is now live, restart your launcher to get it, or download it pre-patched here:

https://rebornpatch.orbusvr.com/file/orbusvr/update/RebornLauncher-2.95.zip

Thanks!


#19

scoundrel change feels great gets rid of that stuck perpetually reloading feel and retains ammo for the final pushes


#20

I tried to report the bug from the tool, but it not worked. So I’m posting it here.

Good evening.
Not able to equip or delete the fishing rod. I owned one from the original Orbus and could not use it. Then I purchased one from the Cheff thinking that I could start fishing. Still did not work. I put those two in the player house chest thinking that somehow would reset it. So I purchased another one at the Cheff. Now I have 3 fishing rods that I can’t use and its wasting space in my inventory and chest.


#21

Did you try equipping to tool slot instead of weapon slot?