Closed Beta Launcher Download

There’s a new launcher available for this Closed Beta Test, v0.90. It features an improved download CDN that should work better worldwide, as well as a better way internally of sending large bug reports to me. Please download it below:


You can delete your previous Launcher folder if you already had the game before. Once you install the new launcher, run it and it will begin downloading the latest patch. Thanks!

Download/Installation Instructions

After you download it, extract the ZIP file anywhere on your computer, such as your Desktop or Downloads folder. NOTE: If you extract it to the Program Files directory (or other protected directory) then you will need to use “Run as Administrator…” to run the launcher. So we recommend NOT extracting it to the Program Files folder.

Inside the folder there is an application called “OrbusVR_Launcher.exe”. Just run this to boot up the launcher. Login with your OrbusVR account details and then the launcher will begin to download the latest game files. Once the downloads have completed and the server is online you will see a “Launch Game” button that you can press. The total filesize of the game client is approximately 2GB.

Download complete, now if you could open the server… :smirk:


Seriously! I just need to make sure that the downloaded files are correct, I won’t be long! I “promise”! :joy: Just turn on the servers for a little while? We won’t tell…

1 Like

New updater is installed. Does nothing when I try to sign in. Web page logging in just fine.
What silly thing did I miss this time? :blush:
It should at least say I am putting incorrect password I believe. It will not do that either.

Are you clicking the Sign In button? Sorry it doesn’t work if you just press the Enter key which I think might be what’s going on.

Thanks for the reply Riley.
I have clicked the button manually also,yes. I just got home from work and tried rebooting just for kicks. Launcher is still doing the same thing for me. I put in correct info or incorrect click sign in…nothing happens. I checked just to make sure nothing was popping up in the background also. I can hit create a new account and that works fine. I will try uninstall and reinstall now.

Well I don’t know why but reinstall worked!
It started and went right to updating now. :metal:

Awesome glad to hear it!

1 Like

There’s a new patch that we just released. Just restart your launcher to get it. In particular:

  • Fixed a bug which was causing your Private Messages to get messed up and combined with random others.
  • Fixed a series of bugs relating to login screen that may have been causing too many errors to let people log in properly.
  • Re-designed the layout of the Desert Dungeon so that the pulls aren’t so crammed together. Also adjusted some pulls.
  • There is now a Female NPC standing next to Bishop Roma who will give you 500 dram when you talk to them in at University Island (Next to Guild City). Use that for repairs.
  • Fixed the Parables quest responses for Sicilus.

400 dram, I’m rich. You should put that person next to my stall:) lol

Hello ! sry for my english, i m from france ! Just bought my founder account for this beta :smile:

Just to say, i got the same problem like Rev_K, sign in button did nothing.

I just deleted the launcher, unzip it to an other location. and relaunch !

An we re good ! launcher after sign in, starting to update the game ! thx for tips guys (delete , and re unzip)

See ya in game :slight_smile:

1 Like

Downloading using patcher takes forever from Germany less then 1MB/s… this sucks ;(

There is an alternate download option available here for the current latest version:

1 Like

That helps a lot! Thank you. Could u always provide the link to the google drive at the same place when releasing an update? The patcher unfortunately is no real option for me :confused:

Yes, we’ll update this thread with the versions, and once we enter early access you’ll be able to download from oculus/steam directly so it’ll be quicker.

1 Like