Reborn Patch 10.87

#1

There’s a new patch out today on client and server with the following changes:

  • Hit detection on ranged classes was re-worked a bit to make it more reliable when enemies are moving quickly.
  • Fixed an issue which could cause the first boss in the Crypt Dungeon to get stuck sometimes.
  • Fixed an issue with a couple of legacy achievements (one was removed which was never obtainable in the old game).
  • Made some changes to the AoE warning indicator so it should work more reliably and also not turn off prematurely when you aren’t actually out of the AoE area.
  • There’s been some updates to the Auction House UI to remove the drop-down menus and instead switch to a system of icons for the categories along with a scrollable list for the items. This should be compatible with Quest and just in general be faster to use.
  • Note: Artificing Tile names are still not showing properly, we are working on a fix.
  • Fixed an issue which could cause your grabber to stop working (e.g. unable to grab things like loot or chests).
  • Bolt-casting enemies (e.g. the ones that fire Wild Bolts) will now always cast both bolts in the same direction no matter what.

This will be rolling out on the client in around an hour and the server in about 45 minutes. Note that beginning today we can put out Quest patches as often as we’d like, so this update will bring the Quest into line with the PC version and we will be putting out patches at the same time on Quest from here on out.

Thanks!

14 Likes
Issue with ranger hits not doing damage
#2

Patch should now be rolling out on all store platforms client-side.

#3

massive improvement on the AH UI, but you should probably add some tool-tips to the category icons

5 Likes
#4

Server-side part of the patch is now deployed as well. Thanks!

split this topic #5

3 posts were merged into an existing topic: Websocet conection

#6

That’s sooo awesome I began filtering things, for the very first time :slight_smile:

1 Like
#7

Ummm, my UI bugged

3 Likes
#8

it’s like UI inception

1 Like
#9

Relogging doesn’t fix it lol

2 Likes
#10

I don’t exactly see the issue? I thought this was a feature… :wink:

2 Likes
#11

haha you so funny

#12

Is anyone else seeing this issue?
Could you try doing a computer restart and see if that works? If not just send an output log and we’ll take a look for you.

#13

Client restart fixed it, hasn’t happened again, if it does I’ll send the log

#14

Perfect, thanks!

#15

Hmmmm, I have a problem with this update. Now I only have myself to blame when I screw up dodging bolts. Can we roll this back some?

Looking forward to running some shards and checking out this update. The last one already helped quite a lot. Thanks for working on this mechanic some more!

2 Likes
#16

Happened again, sending log now Sent log

1 Like
#17

Hmm ok we’ll take a look at the logs. Sorry about that.

#18

Did it happen while you were already playing suddenly or did it happen after a relog or restart of the client?

#19

After a relog

#20

i got the issue that rickness got when i log out and log back in i got the crazy menu i fix it by closing and relunching orbus