The bow bugs followup!

As you can see in the first part of the video I managed to recreate a bug where the bows draw string is still pulled back.

I was fighting enemy’s testing out my bow sensitivity issue and got killed while pulling back the bow. I then respawned and my bow string was pulled back indeffently.

Now the bow jipping issue:

it seems to be and issue when the bow and arrow are combined tried both hands and the same issue persists. Half way through the video you see me manipulate both separately and they seem very smooth.

So yeah that is definitely a known issue, thanks for letting us know about that one, but I think that is a separate issue. If that happens again you can just re-log for now to fix it.

Like if you look at the video at 0:50-ish, where you have the arrow around the notch point and it is jumping back and forth between two positions, is that you pressing and releasing the Trigger over and over again? Or…?

Even if you look at 2:12, where you have them separate, you can see how “jerky” they are while you are rotating them. If you are just standing still and moving them slowly, do they still jerk around that much?

Also just to make sure all the relevant info is in this new thread, you’re using Oculus Rift with 3 cameras, right?

For reference, here is what it looks like on my 3-camera Oculus test rig:

Right at 50ish that was actually an issue with the bow string being in the wrong location. It seems to have shifted the arrow insertion point, this was causing me in the real world to hit the controllers together in order to put the arrow in the bow.

Yeah oculus rift 3 sensor setup.

I just had a thought I watched the video through a few times now and if you watch the bow when it’s jipping out it appears to be flipping 180 degrees at most points. Now I’m not sure but I assume each model has a fixed up position? If this is the case then when combining the arrow and the bow could the game get confused last to what is left and right hence it starts flipping the bow over 180?

Hmm that seems pretty fluid to me have you tried holding the arrow cocked then rotating both your controls on their axis?

Its just really weird everything seems so fluid until i merge bow with arrow?

Okay, yeah we should probably record a clean video without the string-messed-up part, since as I said that is definitely a bug but it’s a different one (as far as I know).

When the bow is notched, its aim is determined by the angle between both of your controllers. So if one of them is jerking around wildly, it’s going to cause the bow to go all crazy like that. It’s entirely possible that we need to put in some code that interpolates the position of the bow over time instead of instantly so that we can better accommodate setups that don’t have great tracking. But with a 3 camera setup, I wouldn’t think you would have tracking issues.

I really think what I need to see here is just how your controllers look normally. Like at 2:12, I think they are jerky but it’s hard to tell because you are rotating them so quickly it would hide any issues. Try just having your bow and arrow out, and then just turn your body slowly 360 degrees, and while you’re doing that just sort of slowly move/rotate the arrow and bow around. Does the bow and arrow track that perfectly? (It should I would assume). If so then we can hopefully figure out at what point the jerkiness sets in…

Here is me rotating the bow all kinds of crazy ways and then doing the walking slowly around rotating the bow and arrow like I suggested. As you can see, when rotating it really crazy it does sometimes do a jerk (due to it losing tracking and catching back up), but when I turn around slowly it has no issues.

(Also I assume when you recorded that original video you were just aiming like normal and not wildly swinging your arms around or something, haha).

I will have to have another go tommorow as turned the pc off now for the evening plus I haven’t done the update you pushed yet and my internet is slow. I’m just wondering if it’s to Do with my third sensor? My front 2 are left and right of my screen facing up about knee height but my rear one is perched on top of a cabinet looking down this i would imagine gives it a better view of both controls so it might be that?

Okay no worries. I’m sure we’ll get it figured out.

That sounds like a fine placement to me. It might just need to be recalibrated or something.

1 Like

I have my setup with each sensor in the top 3 corners of my room pointed slightly down toward the center. I have no tracking issues at all. I had to install corner shelves to accommodate the setup but worth it. I did have to put something under my sensors to allow them to angle down a bit more than the stand allows.

1 Like

I will set up my webcam to so you cam see what I’m doing it’s only 720p but it might help?

The more info the better!

So I had this bug happen as well tonight. Another thing I noticed when this happens is that the “Hold Point” on the arrow is moved up towards the middle of the arrow. Normally it is at the back end with the tailfeathers. I am able to fix the bow string pullback bug by equipping a sword and then going back to the bow, but the arrow grip stays messed up and it throws up the shooting enough to make it brutal. Relogging is the only way to seemingly fix that.

Just to make sure, by “this bug” you mean the part where the bow string is getting stuck and the arrow grip is messed up, not the part about the bow going crazy and wild when the string is not messed up, right?

Yes bow string getting stuck in fully pulled position and the arrow grip gets closer to the center of the arrow.

Here’s some more gameplay of the issue. The early shuddering is my wrist shaking when I bend it to far to the right. Near the end all I’m doing is holding the bow dead strait and pulling back on the arrow and it’s causing it to spin the bow wildly.

So yeah it seems to me like something is definitely going on with your tracking or something. When you rotate your controller to the left/right like that, your tracking should not be “jerking” like that…it’s snapping back-and-forth nearly 45-degrees at a time when you have it rotated, which you can really see for example at 0:10. Do you think you are losing line-of-sight between your controller and cameras when that happens? I almost wonder if you have a faulty controller or something. That or maybe there is some sort of interference between your controller and your PC so the data stream isn’t sending right?

Did you try running through the Oculus calibration device setup process again from the start?

I do think I can put in some stuff that can help with this, since it looks like what’s basically happening is your controller is just reporting an incorrect value about every 10ms out of 100ms or something, so I can smooth out the input to help. But just generally speaking, for the sake of your setup and other games I would try re-calibrating it and even contact Oculus and let them know what’s going on, because that’s not normal controller behavior. (Hopefully someone else can back me up on that, haha)

I will try some extra steps when I next go on think maybe a clean install of the game will help? All other games the tracking works fine. Even in your one using the gun is fine and holding the shield is all good it’s just the bow that seems to have the issue.

So I think the tracking issues are still there, it’s just that for those it’s not noticeable…like I said I will definitely see if I can make some adjustments on the bow to help. A clean install of the game would not make any difference I don’t think.

I would like to chime in and say I have a issue with the tracking and bow spinning as well just got the game and during the tutorial it took me 15 minutes to kill the dummie because the bow kept swapping positions throwing off my aim

editing using oculus in 3 sensor setup